people using single letter argument/variable names for anything that isn't a counter should please reconsider their naming choices.

this is me after looking at parts of the Misskey codebase and having x and y function arguments in places that have absolutely nothing to do with coordinates.

@pixel If your function is only 10 lines, it's not a big deal. Variable's name length should be inversely proportionate to its scope.

@p even if it's a few lines, depending on the method I'd like it to be at least a tiny bit descriptive so I don't always have to backtrack the entire function to know what exactly I'm dealing with

@pixel That function seems somewhat unclear.

(Also JS keeps gradually evolving into Perl.)

@p this prepares the responses from the API handler in Misskey

not particularly in a good way, however.

currently looking at this because I'm implementing sane HTTP verb usage for the Foundkey API and I'd like to have actual REST back but stuff like DELETE .../note/:id is not possible because all handling just expects post vars and the url params are never even considered.

Sign in to participate in the conversation

Welcome to, pixeldesu's personal Mastodon instance!